嵌入式linux热门培训内容之Linux内核发现两个没有被修复的DoS漏洞


目前已经确认Linux Kernel 4.19.2中存在CVE-2018-19406漏洞,允许本访攻击者在未修复设备上使用精心制作的系统调用来达到DOS状态。触发这个问题的原因是高级可编程中断控制器 (APIC)无法正确初始化所导致的。


Li在他的公告中写道:“apic映射尚未初始化,在测试案例中使用vmcall触发pv_send_ipi接口,结果导致kvm-> arch.apic_map被解除引用。”


Linux内核发现两个没有被修复的DoS漏洞Linux内核发现两个没有被修复的DoS漏洞。


Li发现的第二个漏洞,仅限于攻击者可以物理访问设备的情况。该问题在CVE库中编号为CVE-2018-19407,出现在Arch/x86/kvm/lapic.c源代码文件中的kvm_pv_send_ipi功能内核函数中。由于I / O高级可编程中断控制器(I / O APIC)无法初始化,本地攻击者可以通过提交恶意的系统调用来触发NULL指针延迟条件来拒绝服务。


立即咨询有惊喜哦 !